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Summary 

Visualisation of neuronal activity during animal behaviour is a critical step in 

understanding how the brain generates behaviour. In the model vertebrate zebrafish, 

imaging of the brain has been done mostly by using immobilized fish. Here we describe 

a novel method to image neuronal activity of the larval zebrafish brain during prey 

capture behaviour. We expressed a genetically encoded fluorescent calcium indicator, 

GCaMP, in the optic tectum of the midbrain using the Gal4-UAS system. Tectal activity 

was then imaged in unrestrained larvae during prey perception. Since larval zebrafish 

swim only intermittently, detection of the neuronal activity is possible during swimming 

bouts. Our method makes functional brain imaging under natural behavioural 

conditions feasible, and will greatly benefit the study of neuronal activities that evoke 

animal behaviours.  

 

Introduction 

To understand how neuronal activity generates behaviour, it is desirable to record 

neuronal activity from a freely behaving, unrestrained animal. Electrical activity of 

neurons can be indirectly measured by detecting the voltage-gated calcium influx. 

Development of fluorescent calcium probes and advancement in imaging technology has 



made it possible to simultaneously record from multiple neurons [1]. However, imaging 

of an animal in motion is technically challenging, because the movement of the brain 

results in blurred images. Therefore, most calcium imaging studies involve restraining 

the animal. In larval zebrafish, for example, the fish are partially restrained by 

embedding them in agarose [2-4]. This experimental setup raises concerns on possible 

stress-related activity that is irrelevant to the behaviour to be studied. Another concern 

is that behavioural study is limited by the fact that a partially restrained larva cannot 

show the full spectrum of its behavioural repertoire. Thus, the use of free-swimming 

(i.e., unconstrained) fish in functional brain imaging is essential to study physiologically 

relevant neuronal signals and complement studies that used restrained larvae. 

 

Because zebrafish larvae show only intermittent swimming activity, we can conduct 

calcium imaging of the brain and detect fluorescence changes during the quiescent 

periods. Here we describe the detection of calcium signals in the optic tectum of the 

midbrain during visual perception of a paramecium (prey for the larvae). To suppress 

movement of the larva along the Z-axis (i.e., moving out of the focal plane), we used a 

shallow chamber (0.8 mm in depth) that we found suitable for 4-7 day old larvae. The 

small diameter (9 or 13 mm) of the chamber provided an arena for zebrafish larvae to 



exhibit prey capture behaviour, while reducing the need to move the XY stage to keep 

the larvae within the camera view. To maximise the size of the camera view while 

obtaining a fluorescent image that was bright enough, we used a 2.5×/N.A.0.12 or 

5×/N.A.0.15 objective lens.  

 

Detection of neuronal activity in a subset of cells can be observed with an 

epifluorescence microscope (i.e., without confocal microscopy) when these cells are 

specifically labelled with a functional probe. Specific labelling can be achieved by 

expressing genetically encoded calcium indicators (GECIs) such as GCaMP [5], whose 

expression can be driven by a specific promoter, or by using the Gal4-UAS system [6-8]. 

A collection of Gal4FF (a variant of Gal4[9]) driver lines with specific expression 

patterns has been generated, and some of them express the UAS effector in subsets of 

neurons in the brain [10]. Because the pigments on the body surface block both 

excitation and emission light, we used a mutant strain, nacre, which has no 

melanin-producing cells except for those in the retinal pigment epithelium [11]. In this 

chapter, we show an example of a study on vision, but the same principle may be applied 

to the study of other sensory modalities, such as olfaction and gustation with 

appropriate Gal4 lines.  



 

Materials 

1. Preparation of zebrafish larvae  

1. UAS:GCaMP transgenic fish maintained in the nacre mutant background. 

2. A Gal4 transgenic fish with the desired expression pattern, also maintained in 

the nacre mutant background. (See Note 1) 

3. E3 water (5 mM NaCl, 0.17 mM KCl, 0.33 mM CaCl2, 0.33 mM MgSO4, 

0.00001% Methylene Blue)  

4. System water used to maintain the adult fish (Marine Biotech). (Seachem 

Marine Salt is automatically added to reverse osmosis water to a conductivity 

of 470μS. NaHCO3 is used to adjust the pH to 6.8) (See Note 2) 

5. A pressed glass plate with 9 concave depressions 

6. Disposable transfer pipets 

7. Fluorescence stereoscope. We use the Leica MZ16FA FLUOIII with the filter 

set of "GFP2" (Excitation filter:480/40nm (460-500nm), and Barrier filter:510 

nm) 

2. Preparation of paramecia  

1. Paramecia. The paramecia may be obtained from local commercial suppliers, 



other researchers, or the BioResource center in Japan 

(http://nbrpcms.nig.ac.jp/paramecium/).  

2. Rice straw  

3. EBIOS (dry beer yeast, Asahi Food & Healthcare, Co. Ltd., Tokyo, Japan) 

4. 1000 mL autoclavable beaker  

5. 300 mL glass beakers 

6. A squeeze bottle  

7. Funnel  

8. Stainless steel sieves with 75 micron aperture and 150 micron aperture (Tokyo 

Screen)  

9. Nylon mesh (N-No. 508T-K (filtered object size:13 µm), and N-No. 380T (32 µm 

aperture), Tokyo Screen) 

2. Recording chamber 

1. Chamber with a depth of 0.8 mm. We use Secure-Seal Hybridization Chambers 

(13 mm diameter × 0.8 mm depth, GRACE BIO-LABS. Item:621502), or 

Secure-Seal Hybridization Chamber Gasket, 8 chambers, (9 mm diameter x 0.8 

mm depth, Molecular Probes. S-24732)  

2. A slide glass. We use Matsunami micro slide glass Superfrost (MAS-coated) or 

http://nbrpcms.nig.ac.jp/paramecium/


Matsunami micro slide glass (APS-coated). 

3. A cover glass (e.g., Matsunami 24 × 32 mm)  

4. A micro-blade (e.g., Feather Safety Razor Co. Ltd. Micro Feather P-715)  

3. Calcium imaging equipment 

1. Epifluorescent microscope and low magnification objective lenses. We use Zeiss 

Imager.Z1 and 2.5×/N.A.0.12 and 5x/N.A.0.15 lenses. 

2. A camera suitable for fluorescence time-lapse imaging. We used a scientific 

C-MOS camera (ORCA-Flash 4.0 V2, Model:C11440-22CU, Hamamatsu 

Photonics, Japan), and previously used a cooled CCD camera (ORCA-R2, 

Model: C10600-10B, Hamamatsu Photonics, Japan).  

3. Frame grabber (Active Silicon Fire Bird, provided by the camera manufacturer 

as a part of the camera system) 

4. PC for image acquisition. We use a Dell Precision T3610 (recommended by the 

camera manufacturer) with 32GB RAM and 4× 256GB solid state disks in a 

RAID 0 configuration.  

5. Image acquisition software. We use Hamamatsu Photonics HCImage with the 

Hard Disc Recording module. 

6. Image analysis software. We use the freeware Fiji/Image J (http://fiji.sc/Fiji). 



 

Methods 

1. Preparation of the larvae  

1. Set up crosses of the chosen Gal4 line and the UAS:GCaMP line 5 or 6 days 

before the imaging experiment. Collect eggs on the following morning. Raise 

them in E3 water at 28.5 °C. (See Note 3)  

2. Transfer the embryos with a disposable pipet to a pressed glass plate, and view 

under the fluorescent stereoscope. Sort the GCaMP-expressing larvae at an 

early stage if it is being expressed. It is much easier to sort them before they 

hatch or start to swim. We maintain our Gal4FF lines with UAS:GFP as a 

reporter. Thus, a given clutch will contain GCaMP-positive, GFP-positive, and 

double-positive embryos in addition to the non-fluorescent ones. GCaMP 

fluorescence is weaker than GFP fluorescence, and the two could be 

distinguished without difficulty. 

3. Raise embryos in E3 water to 4-7 days post-fertilisation, when they start to 

show prey capture behaviour. Feeding of the larvae is not necessary for up to 1 

week after fertilisation. Remove the chorions and mold as necessary to keep the 

embryos clean during development.  



2. Paramecium culture  

Note that the procedures described here are for the entire system in our lab, so the 

culture volume may be scaled down as necessary.  

1. Autoclave 1000 mL water and 5 g of rice straw in a 1000mL beaker covered 

with aluminium foil for 20 min at 121 °C. This will kill most bacteria but will 

allow Bacillus subtilis, which naturally resides on the rice straw, to survive and 

act as the food source for the paramecia. 

2. Put 3 tablets of EBIOS into the autoclaved water with the rice straw.  

3. On the following day, put 30 mL paramecium solution from the previous 

culture (or the original solution obtained from the supplier) into 1000mL of the 

above EBIOS solution and maintain it at room temperature (approx. 25 °C) for 

2 weeks. After 3 or 4 days, the solution should look cloudy, and then become 

transparent thereafter. (Fig. 1A) 

2. Preparation of paramecia for the use of prey capture behavioural recording  

1. Put the paramecium culture through two sieves (a 150 micron aperture, 

followed by 75 micron aperture) to remove debris (Fig. 1B), then collect them on 

a nylon mesh (N-No. 508T-K) using a funnel (Fig. 1C). Re-suspended them in a 

300 mL beaker using a squeeze bottle of system water. This concentrated 



paramecium stock solution can be kept at room temperature for one or two 

days.  

2. Just before imaging experiments, put a few mL of paramecium stock solution 

into a custom-made tube with a nylon mesh (N-No. 380T; Fig. 1D) submerged 

in system water in a 300 mL beaker. Rinse the paramecia in another 300 mL 

beaker of system water. Only the relatively large paramecia will be left on the 

nylon mesh. After rinsing in system water, transfer the paramecia left on the 

nylon mesh into a small dish using a squeeze bottle of system water. Under a 

stereo microscope, use a micropipette to carefully pick several paramecia that 

show high locomotor activity (Fig. 1E) and transfer them to the recording 

chamber (See section 3-4). 

3. Preparation of a recording chamber 

1. Put the Secure Seal Hybridization Chamber onto a clean slide glass, with the 

adhesive end attached to the slide glass. (See Note 4) 

2. Carefully remove the cover on the other end of the Secure Seal Hybridization 

Chamber.  

3. Using a micro blade, cut the chamber to make a narrow ditch so that the water 

in the chamber is contiguous with the outer water reservoir. (See Note 5) 



4. Put a zebrafish larva and the paramecia into the chamber, fill the chamber 

with system water, and cover with a 36 x 24 mm cover glass (Fig. 1F)(See Note 

6) 

4. Calcium imaging  

1. Set the recording chamber containing a GCaMP-expressing larva and several 

paramecia under an epifluorescent microscope equipped with a fluorescence 

camera. Use an excitation/emission filter set for GFP. We use the excitation 

light (a mercury lamp) at maximal intensity to obtain the best possible quality 

of the image as long as the excitation light showed no toxic effects.  

2. Let the larva adapt to this new environment. The locomotor activity may vary 

from individual to individual or over time. For the larva, adaptation to the new 

environment (i.e., the recording chamber and the excitation light illumination) 

may take approximately 20-30 minutes. 

3. Focus on the larval brain and start time-lapse imaging with the selected image 

acquisition software (HCImage in this case). (See Note 7) 

4. Place the larva at the centre of the camera view by manually moving the XY 

stage of the microscope to ensure that the behavioural event (e.g., prey capture) 

will happen in the camera view. (See Note 8) 



5. After recording, open the movie file in ImageJ with the Bio-Formats plug-in 

(openmicroscopy.org). (See Note 9) 

6. Although calcium signals may be readily recognizable in the raw fluorescence 

images in some cases, their visualisation can be enhanced by image processing 

(Fig. 2B and D). To quantify the changes in fluorescence intensity, divide the 

individual frames by a reference image (an averaged image over all frames, or 

an averaged image over a period with no calcium signals)(Fig. 2 A-D). To do 

this, from the menu in ImageJ, choose Image > Stacks > Z project ... > Average 

Intensity, and then, Process > Image Calculator... > Divide (with the option of 

"32-bit (float) result"). An appropriate look-up table (LUT) can be chosen for the 

best presentation of the calcium signals in pseudocolour. The averaged pixel 

values in a region of interest (ROI) can be measured as follows: create the ROI 

on the image of a stack, set the measurements by choosing Analyze > Set 

Measurements … > Mean gray value, and select Plugins > Stacks > Measure 

Stack. (See Note 10) 

 

Notes 

1 Because the pigments (melanophores) on the surface of the body block light, we 



use the nacre mutant background, which lacks melanophores. Retinal pigment 

epithelium is present in nacre, assuring normal vision. We maintain both the 

Gal4FF and UAS:GCaMP lines on the nacre background so that when mated, 

the clutch contains nacre homozygotes with Gal4FF and UAS:GCaMP 

transgenes. For the study of vision-independent behaviour, phenylthiourea 

(PTU)-treatment can be used to suppress melanin formation as an alternative. 

2 We use system water for behavioural recording, but E3 water (without 

methylene blue) may be used instead. 

3 The choice of the Gal4 line depends on the neurons from which you would like 

to record. A database is available at the Kawakami lab website for Gal4FF 

enhancer/gene trap lines that were generated in our lab [10]. The expression 

level of the GCaMP transgene is critical for detection of calcium signals. When 

the expression level of GCaMP is not high enough, one option is to make the 

UAS:GCaMP homozygous (i.e., express two copies of the transgene).  

4 We constructed the custom-made recording chamber beforehand, and found 

that the depth of 0.8 mm is appropriate to minimise the movement of a 4-7 day 

larva along the Z-axis, while still allowing it to freely swim in the XY plane. A 

smaller chamber (9 mm in diameter) may also be used to increase the chance of 



capturing and recording behavioural events (Fig. 1G). 

5 Because of the small volume of the shallow chamber, the water will rapidly 

evaporate, and possibly change the fluid pressure. To prevent this, a cut was 

made with a fine blade to make a canal to an external reservoir, so the water 

pressure inside the chamber will stay the same as outside.  

6 Once transferred from the concentrated culture to system water, motility of 

paramecia decreases over time. Prepare them fresh for the imaging study.  

7 Typically, the exposure time we use is 10-100 msec, with a frame acquisition 

rate of 10-100 fps and 2x2 binning.  

8 Even with the low magnification lens (2.5x objective lens) and a wide area 

camera (ORCA Flash4.0), only a part of the recording chamber can be viewed 

and recorded. For this reason, a particular behavioural event such as prey 

capture occurs only occasionally in the camera view.  

9 The Hamamatsu Photonics ORCA camera uses the .cxd file format to save the 

movie. This format can be imported into ImageJ with the Bio-Formats plugin 

(openmicroscopy.org). 

10 With the reflected excitation light, the paramecia are visible to human eyes, 

and therefore apparently to the zebrafish larva. However, they are not easily 



recognisable in the fluorescent images, as they have no innate fluorescence nor 

do they have a fluorescent label. The addition of a slight amount of bright field 

illumination during fluorescent imaging may help to visualise the paramecia in 

the image. 
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Figure legends 

Fig. 1. Preparation of the paramecia and GCaMP imaging set up. A) A two-week culture 

of paramecia. The culture becomes transparent after 3 or 4 days, as shown in this 

picture. B) Sieves to remove debris from the paramecium culture. C) Collection of the 

paramecia in the flow-through from filtration in B onto a nylon mesh. D) A nylon mesh 

to size-filter paramecia for visual stimuli. E) Paramecia prepared through steps A-D, 

photographed in dark-field illumination. Scale bar = 0.5 mm. F) A zebrafish larva in a 

recording chamber with a diameter of 13 mm and depth of 0.8 mm. Scale bar = 5 mm. G) 



A zebrafish larva in a recording chamber with a diameter of 9 mm and depth of 0.8mm. 

Scale bar = 5mm. H) A GCaMP-expressing zebrafish larva and paramecia in a recording 

chamber placed under a fluorescent microscope. Excitation light (blue) for GFP was 

used for GCaMP recording. The excitation light also serves to make visible the 

paramecia to both the zebrafish larva and the naked eye. Optionally, bright-field 

illumination can be simultaneously used to make the paramecia more easily 

recognisable in the camera view.  

 

Fig. 2. Calcium imaging of free-swimming zebrafish larvae expressing GCaMP7a in the 

optic tectum of the midbrain. UAS:GCaMP7a transgenic fish and the gSA2AzGFF49A 

Gal4FF driver line were used. A-F) Frames from a time-lapse recording. The 

paramecium is delineated by a line. Insets: Ratiometric image of the frame divided by 

an averaged frame. Scale bar = 0.5 mm. 
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